Results 1 to 4 of 4

Thread: I knew better!

  1. Top | #1
    Forum Newbie
    Array Hallcolr's Avatar
    Join Date
    Oct 2016
    Last Online
    10-23-2016 @ 08:24 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I knew better!

    Hey fellas, and or ladies!
    New to the forums so please bear with me here.. I have a 2008 cobalt.2.2l. Got it for a great deal, however, needed a new crankshaft due to rid bearing going bad and gouging the crap out of it...Appearently people don't know a knock is a bad sound... Anyways..I figured it would be a great project for me and my boy to do together. Have done numerous bottom end projects..none on a 2.2.. So we tore it all apart got all the new parts..bolts, sealants, etc..etc..
    Got to installing the new crankshaft..yes verified oil clearance with plastige and all.. Was going to put the old crankshaft reluctor on the new crankshaft..realized the 58tooth reluctor bolts into the old crank and yet there is not bolt holes on the new crankshaft to attach the reluctor! The new crankshaft did not come with a new reluctor..and they are hard to find apperently! Here's where the problem lies!!! I have reasearched and see that the old style had a 7x and the new has a 58x.. Yet I cannot find actual good pictures of either..was the old 7x pressed on or bolted on? I'm curious if they sent me the wrong one..that being said..any pictures or info would be greatly appreciatedd

  2. Top | #2
    Official Forum Whore Array DaFlyinSkwirl's Avatar
    Join Date
    Apr 2006
    Last Online
    10-21-2016 @ 06:27 PM
    Location
    Jackson, New Jersey, United States, 105823542791088, Jackson, New Jersey
    Posts
    1,057
    Thanks
    0
    Thanked 3 Times in 2 Posts
    did you look at the crankshaft yet?

    the older style cranks do not have a bolt-on reluctor, it's cast into the counterweight for the number 4 piston. you bought the wrong crankshaft.


  3. Top | #3
    Forum Newbie
    Array Hallcolr's Avatar
    Join Date
    Oct 2016
    Last Online
    10-23-2016 @ 08:24 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wow..yep they gave me the wrong one! Damn! That's it that's the one I got! As the thread said..I knew better..reason being..before doing much research at the time..I saw it was notched in the counterweight and thought hmm maybe they re did the crankshaft in an upgrade..complete re installed engine and fired her up..only knew of issues due to p300 codes..and thought before I continue to tear apart of ask and see if that's the issue I got for sure...thank you for the quick response and the info..thought about making the old reluctor external..but doesn't seem to be so easy with the 58t one!

  4. Top | #4
    Forum Newbie
    Array Hallcolr's Avatar
    Join Date
    Oct 2016
    Last Online
    10-23-2016 @ 08:24 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Or has anyone found out a way to use old sensor and crank in newer model?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •