Page 13 of 13 FirstFirst ... 3910111213
Results 145 to 151 of 151

Thread: What car is my ecotec motor from?

  1. Top | #145
    Senior Member
    Array EFIHARNESS's Avatar
    Join Date
    Jul 2011
    Last Online
    10-02-2017 @ 11:02 AM
    Posts
    120
    Thanks
    0
    Thanked 14 Times in 14 Posts
    You can duplicate the tune in another ecu with efi live or hp tuners. Questions, PM me. Steve

  2. Top | #146
    Forum Participator
    Array Stevie's Avatar
    Join Date
    Jan 2014
    Last Online
    06-24-2016 @ 10:52 PM
    Posts
    74
    Thanks
    12
    Thanked 0 Times in 0 Posts
    After all this I finally found where my motor came from, it's a 2.4 LEA from a late model Equinox
    Wonder if I should have it dyno'd, it has higher compression and more horsepower than the LE5
    I bet it has the standard AFI tune on the ECU

    Oh yeah, new fuel cell


    and taking San Felipe by storm
    Last edited by Stevie; 04-18-2016 at 06:36 PM.

  3. Top | #147
    Osirus of this S**t
    Array nogo04cav's Avatar
    Join Date
    Dec 2009
    Last Online
    12-08-2017 @ 07:57 PM
    Posts
    2,025
    Thanks
    0
    Thanked 46 Times in 45 Posts
    How did you find out where it came from? Nice tires by the way!
    More humans=more problems
    Don't worry nothing will be done until it's too late, there is money to be made.
    Maximum profit and overpopulation will ruin all the major economies.

  4. Top | #148
    Senior Member
    Array EFIHARNESS's Avatar
    Join Date
    Jul 2011
    Last Online
    10-02-2017 @ 11:02 AM
    Posts
    120
    Thanks
    0
    Thanked 14 Times in 14 Posts
    You do not have an LEA, as the LEA is direct injection. The intake is very different and there is a high pressure pump (2000 psi) on the end of the cam. The pict you put up is not the #'s you need. look below that where the starter mounts. Also the white tag on the valve cover will tell
    date of mfg using the rpo code. Steve
    Last edited by EFIHARNESS; 04-19-2016 at 12:19 AM.

  5. Top | #149
    Forum Participator
    Array Stevie's Avatar
    Join Date
    Jan 2014
    Last Online
    06-24-2016 @ 10:52 PM
    Posts
    74
    Thanks
    12
    Thanked 0 Times in 0 Posts
    How did you find out where it came from? Nice tires by the way!
    nogo04cav Quoted Post
    Thanks, I got it from the manifold numbers

  6. Top | #150
    Forum Participator
    Array Stevie's Avatar
    Join Date
    Jan 2014
    Last Online
    06-24-2016 @ 10:52 PM
    Posts
    74
    Thanks
    12
    Thanked 0 Times in 0 Posts
    You do not have an LEA, as the LEA is direct injection. The intake is very different and there is a high pressure pump (2000 psi) on the end of the cam. The pict you put up is not the #'s you need. look below that where the starter mounts. Also the white tag on the valve cover will tell
    date of mfg using the rpo code. Steve
    EFIHARNESS Quoted Post
    the intake does look different

  7. Top | #151
    Forum Participator
    Array Stevie's Avatar
    Join Date
    Jan 2014
    Last Online
    06-24-2016 @ 10:52 PM
    Posts
    74
    Thanks
    12
    Thanked 0 Times in 0 Posts
    Hi guys!
    Another question
    I bought a new 091 trans from Benco Racing Transaxles
    When I put it in there was a knocking noise in third and fourth gears
    Benco had it picked up and they said they went through the whole trans and nothing was wrong with it
    I put it back in and I still have the knocking in third and fourth
    First, second and reverse are fine
    Benco said to check the pilot bearing in the adapter setup
    I got about 60 hours of tearing apart the car and installing and reinstalling the trans
    I can't take much more
    What do I do next?
    Btw hope you guys are doing great!


Page 13 of 13 FirstFirst ... 3910111213

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •