Results 1 to 4 of 4

Thread: 06 Cobalt Rough Idle/Stall when stopping or quick deceleration

  1. Top | #1
    Forum Newbie
    Array dragon300zx's Avatar
    Join Date
    Dec 2009
    Last Online
    01-06-2010 @ 07:33 AM
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    06 Cobalt Rough Idle/Stall when stopping or quick deceleration

    Hello All,

    Here is the problem I have.

    06 Cobalt LT 2.2l 103065 Miles

    When decelerating on the freeway to come to a virtual stop for traffic, when stopping at a stop light, when pulling out of the driveway, or at any point when the RPM's fall quickly to idle speed I have an irratic idle.

    Idle will fluctuate between 300-750 rpms

    Normal idle is around 750 rpms

    This morning it actually stalled when I was pulling up to a stop sign to pull out of my subdivision. It did restart right away.

    When the Idle is rought the lights dim on the car, power steering becomes weak, and other problems you would expect when your idle drops and your car is about to stall.

    No check engine lights come on at all (I wish they did, I have a nice scantool).

    If I decelerate slowly, or have been driving at even driving conditions (not alot of accelerating then decelerating) this doesn't really happen.

    Any ideas? Has anyone had this happen?

    I just bought this car alittle over a month ago and rely on it so I need to figure this out and get it fixed.

  2. Top | #2
    Forum Newbie
    Array rsscamaro315's Avatar
    Join Date
    Dec 2009
    Last Online
    12-19-2009 @ 09:50 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    sounds like the problem i had it ended up being the idle air sensor

  3. Top | #3
    Forum Newbie
    Array rsscamaro315's Avatar
    Join Date
    Dec 2009
    Last Online
    12-19-2009 @ 09:50 PM
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    find resistance values and test with an ohm meter

  4. Top | #4
    Forum Newbie
    Array stonedgoat's Avatar
    Join Date
    Dec 2009
    Last Online
    12-27-2009 @ 03:05 PM
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello All,

    Here is the problem I have.

    06 Cobalt LT 2.2l 103065 Miles

    When decelerating on the freeway to come to a virtual stop for traffic, when stopping at a stop light, when pulling out of the driveway, or at any point when the RPM's fall quickly to idle speed I have an irratic idle.

    Idle will fluctuate between 300-750 rpms

    Normal idle is around 750 rpms

    This morning it actually stalled when I was pulling up to a stop sign to pull out of my subdivision. It did restart right away.

    When the Idle is rought the lights dim on the car, power steering becomes weak, and other problems you would expect when your idle drops and your car is about to stall.

    No check engine lights come on at all (I wish they did, I have a nice scantool).

    If I decelerate slowly, or have been driving at even driving conditions (not alot of accelerating then decelerating) this doesn't really happen.

    Any ideas? Has anyone had this happen?

    I just bought this car alittle over a month ago and rely on it so I need to figure this out and get it fixed.
    dragon300zx Quoted Post
    yeah i've got pretty much the same issue it's been happening the past year or so so once the holidays are over with i hope i'll get the extra $ to start fixing it. i'm going to start with looking at the coil plugs and go from there since it seem just like all other issues i've been reading on the forums on here and other ecotec forums.

Similar Threads

  1. 2003 Cavalier with rough idle/shaking
    By KeithICb in forum 2.2 General Problems
    Replies: 9
    Last Post: 04-09-2011, 06:32 PM
  2. [SOLVED] rough idle and dying
    By Scrapz253 in forum 2.2 General Problems
    Replies: 11
    Last Post: 06-26-2010, 04:34 PM
  3. [SOLVED] 04 rough idle and surge
    By Kipn in forum 2.2 General Problems
    Replies: 2
    Last Post: 05-06-2010, 01:51 PM
  4. Stalling, rough idle, misfiring
    By 03crazycavy in forum 2.2 General Problems
    Replies: 13
    Last Post: 03-08-2009, 05:06 AM
  5. Rough idle. poss. vacuum leak??
    By GMPARTSPRO in forum 2.2 General Problems
    Replies: 24
    Last Post: 02-27-2009, 01:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •